Avatar
Jorge Erasmo Medina Suarez

@jorgeerasmomedinasuarez70357

Como mencioné antes, ésta es la solución al ejercicio que implementé (hay varias maneras de resolver este ejercicio):

Definir mensaje, letras, codigo, respaldo,compara Como Caracter; Definir numerito, i, cantidad Como Entero; Escribir "Introduzca el mensaje de texto que desea enviar: "; Leer mensaje; letras = ""; codigo = ""; respaldo = ""; cantidad = Longitud(mensaje); Para i = 0 Hasta (cantidad - 1) Hacer compara = ""; letras = Subcadena(mensaje,i,i); compara = Alfabeto(letras); Escribir Subcadena(compara,0,0), " - ",Subcadena(respaldo,0,0); Si Subcadena(compara,0,0) = Subcadena(respaldo,0,0) Entonces codigo = codigo + " " + Alfabeto(letras); SiNo codigo = codigo + Alfabeto(letras); FinSi respaldo = compara; FinPara Escribir "El codigo del mensaje ",mensaje," es: ",codigo; FinAlgoritmo Funcion equivalente <- Alfabeto(palabra) Definir equivalente Como Caracter; equivalente = ""; Si palabra = "a" Entonces equivalente = "2"; SiNo Si palabra = "b" Entonces equivalente = "22"; SiNo Si palabra = "c" Entonces equivalente = "222"; SiNo Si palabra = "d" Entonces equivalente = "3"; SiNo Si palabra = "e" Entonces equivalente = "33"; SiNo Si palabra = "f" Entonces equivalente = "333"; SiNo Si palabra = "g" Entonces equivalente = "4"; SiNo Si palabra = "h" Entonces equivalente = "44"; SiNo Si palabra = "i" Entonces equivalente = "444"; SiNo Si palabra = "j" Entonces equivalente = "5"; SiNo Si palabra = "k" Entonces equivalente = "55"; SiNo Si palabra = "l" Entonces equivalente = "555"; SiNo Si palabra = "m" Entonces equivalente = "6"; SiNo Si palabra = "n" Entonces equivalente = "66"; SiNo Si palabra = "o" Entonces equivalente = "666"; SiNo Si palabra = "p" Entonces equivalente = "7"; SiNo Si palabra = "q" Entonces equivalente = "77"; SiNo Si palabra = "r" Entonces equivalente = "777"; SiNo Si palabra = "s" Entonces equivalente = "7777"; SiNo Si palabra = "t" Entonces equivalente = "8"; SiNo Si palabra = "u" Entonces equivalente = "88"; SiNo Si palabra = "v" Entonces equivalente = "888"; SiNo Si palabra = "x" Entonces equivalente = "9"; SiNo Si palabra = "y" Entonces equivalente = "99"; SiNo Si palabra = "z" Entonces equivalente = "999"; SiNo Si palabra = " " Entonces equivalente = "0"; SiNo Escribir "Por favor, introduzca un caracter acorde al teclado."; equivalente = "ERROR"; FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinSi FinFuncion
Avatar
Jorge Erasmo Medina Suarez

@jorgeerasmomedinasuarez70357

Este es el algoritmo que he visto con varias maneras de resolver y todas son factibles, la solución que le conseguí por mi cuenta no es ni remotamente parecido pero funciona. En el próximo vídeo subo el Pseudocódigo.

Avatar
Jorge Erasmo Medina Suarez

@jorgeerasmomedinasuarez70357

Fue un reto muy interesante ya que te obliga a trabajar con String y utilizar los conocimientos del tema de Conversión de un número decimal (base 10) a un número con base desde el 2 hasta al 9. Y es genial aprender sobre los números palindromos.

Avatar
Jorge Erasmo Medina Suarez

@jorgeerasmomedinasuarez70357

Estén muy pilas cuando pregunten por una variable, ejemplo: a. Si preguntan a!=0; en javascript lo interpretará como un valor lógico. Ejemplo: si a existe y es diferente de 0, a= true; caso contrario, a=false. Establezcan bien las condiciones si trabajan con enteros

Amigos

Jorge aún no tiene un enlace de referidos

Si eres estudiante premium ya tienes el enlace en tu perfil de usuario. Si aún no eres premium recibirás tu enlace de referidos como recompensa cada vez que completes un curso gratuito.

Más información

Estos son los beneficios que tú y Jorge recibirán si compras con su enlace de referidos 🙌

BeneficiosMensualSemestralAnual
Descuento ()$ 3 USD$ 15 USD$ 30 USD
Semanas gratis (Jorge)1612

Al comprar con el enlace de referidos aceptas los términos y condiciones

Publicaciones
Certificados
Me gusta
Referidos