Porque no carga el background-image mi imagen ?

Avatar

Tengo un problema, he usado el background-image antes, ahora estoy haciendo una pequeña practica, y si aparece la imagen como fondo en un contenedor, pero cuando apago mi equipo y todo y vuelvo abrir el proyecto para continuar ya no carga el fondo, la ruta esta bien y todo, pensé que era algo que hice mal así que lo deje pasar, luego empece otra practica y use de nuevo un fondo como imagen y paso nuevamente lo mismo, es como si no existiera la imagen o no lo este ubicando, ya accedí a la raíz directamente y lo hice saliendo de las carpetas una por una pero nada, no me carga la imagen.

.header{
background-image: url(./img/bg.jpg);
}
15respuestas
Avatar
.header{
background-image: url(../img/bg.jpg);
}

son 2 puntos me comí una al ponerlo, error mio. Pero ese no es el problema.

Avatar

Prueba darle

    background-image: url(../Programacion/img/gmail.png);
    background-size: contain;
    width: 20vh;
    height: 20vh;
}
Avatar

Vh no lo puedes usar en Width porque eso es para el height, 'vw' se usa para el ancho. Y hay que tener cuidado con esas medidas relativas al viewport.

Avatar

Tienes razón me equivoque con el width. Gracias

Avatar

Es solo un ejemplo prueba a ver si te funciona

Avatar

Prueba darle ` css

header { background-image: url(../Programacion/img/gmail.png); background-size: contain; width: 20vh; height: 20vh; }

Avatar

Hola marco.

Es probable que tengas conflictos en tu código. Muestra todo el código tanto del html como del css para tener un panorama mas amplio y así te podremos ayudar mejor.

Saludos

Avatar

Es que la verdad no se si tenga conflictos, uso Visual Studio Code y uso el plugin live server, y cuando lo estoy haciendo directo de allí, me carga la imagen y todo bien, pero al momento de abrirlo directamente del index.html, de plano ya no carga. y pues ya había usado esa propiedad antes y no me había pasado eso.

Avatar

Hola,es posible que se te olvidara guardar el archivo pero tienes que enseñar el código completo para ayudarte. Saludos

Avatar

Muestra tu código HTML, CSS y tu estructura de archivos para tener más detalles de tu problema

Avatar

Es que la verdad no se si tenga conflictos, uso Visual Studio Code y uso el plugin live server, y cuando lo estoy haciendo directo de allí, me carga la imagen y todo bien, pero al momento de abrirlo directamente del index.html, de plano ya no carga. y pues ya había usado esa propiedad antes y no me había pasado eso.

Avatar

Faltan las comillas en tu url.

Avatar

Se puede escribir sin comillas también.

Avatar

Entonces puede ser la ruta el problema, intenta quitarle el slash (/) y los 2 puntos (..)

Avatar

El problema es que no está mostrando el código y así es muy dificil saber lo que está pasando. Puede ser que esté en carpetas más atrás la imagen.

Recuerda iniciar sesión para participar en la comunidad.